summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-09-21 21:47:56 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-09-21 21:47:56 +0200
commit39162ee49b08ccbd032324dc057fbafe8809c8a8 (patch)
tree181e0602ceeaa24bc0dad75bbd554eb37bf5d81a /gnu
parentb78891b0120c2e6f7752912d43bc59e18ed9c465 (diff)
downloadguix-39162ee49b08ccbd032324dc057fbafe8809c8a8.tar.gz
gnu: extempore: Only build on x86_64.
* gnu/packages/algebra.scm (kiss-fft-for-extempore)[supported-systems]:
Only build on x86_64.
* gnu/packages/gl.scm (nanovg-for-extempore)[supported-systems]:
Likewise.
* gnu/packages/image.scm (stb-image-for-extempore)[supported-systems]:
Likewise.
* gnu/packages/llvm.scm (llvm-for-extempore)[supported-systems]:
Likewise.
* gnu/packages/music.scm (portmidi-for-extempore)[supported-systems]:
Likewise.
(extempore)[supported-systems]: Likewise.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/algebra.scm2
-rw-r--r--gnu/packages/gl.scm2
-rw-r--r--gnu/packages/image.scm2
-rw-r--r--gnu/packages/llvm.scm4
-rw-r--r--gnu/packages/music.scm4
5 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 83f03a074a..a15daf4ef8 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -521,6 +521,8 @@ syntax is similar to that of C, so basic usage is familiar.  It also includes
                 "0hkp9l6l4c92fb1l2sh6a6zv1hynpvb2s4d03vd8vxyvybc0l4pv"))))
     (build-system cmake-build-system)
     (arguments `(#:tests? #f)) ; no tests included
+    ;; Extempore refuses to build on architectures other than x86_64
+    (supported-systems '("x86_64-linux"))
     (home-page "https://github.com/extemporelang/kiss_fft")
     (synopsis "Mixed-radix Fast Fourier Transform")
     (description
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 707e3d4d1d..a4ec3a3536 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -591,6 +591,8 @@ and surfaces, receiving input and events.")
     (arguments `(#:tests? #f)) ; no tests included
     (inputs
      `(("mesa" ,mesa)))
+    ;; Extempore refuses to build on architectures other than x86_64
+    (supported-systems '("x86_64-linux"))
     (home-page "https://github.com/extemporelang/nanovg")
     (synopsis "2D vector drawing library on top of OpenGL")
     (description "NanoVG is small antialiased vector graphics rendering
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index e40fa9a47d..931cad1a6d 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -923,6 +923,8 @@ statistical tests.")
                (file-name (string-append name "-" version "-checkout"))))
       (build-system cmake-build-system)
       (arguments `(#:tests? #f))        ; no tests included
+      ;; Extempore refuses to build on architectures other than x86_64
+      (supported-systems '("x86_64-linux"))
       (home-page "https://github.com/extemporelang/stb")
       (synopsis "Image library for Extempore")
       (description
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index b55a200bc5..1a1f7eef6c 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -274,4 +274,6 @@ code analysis tools.")
     (source
      (origin
        (inherit (package-source llvm-3.7))
-       (patches (list (search-patch "llvm-for-extempore.patch")))))))
+       (patches (list (search-patch "llvm-for-extempore.patch")))))
+    ;; Extempore refuses to build on architectures other than x86_64
+    (supported-systems '("x86_64-linux"))))
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index c512d533c2..a7715bce24 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -396,6 +396,8 @@ enable professional yet simple and intuitive pattern-based drum programming.")
     (native-inputs
      `(("perl" ,perl)
        ("emacs" ,emacs-no-x)))
+    ;; Extempore refuses to build on architectures other than x86_64
+    (supported-systems '("x86_64-linux"))
     (home-page "http://benswift.me/extempore-docs/index.html")
     (synopsis "Programming environment for live coding of multimedia")
     (description
@@ -1243,6 +1245,8 @@ using a system-independent interface.")
     (build-system cmake-build-system)
     (arguments `(#:tests? #f)) ; no tests
     (native-inputs '())
+    ;; Extempore refuses to build on architectures other than x86_64
+    (supported-systems '("x86_64-linux"))
     (home-page "https://github.com/extemporelang/portmidi/")))
 
 (define-public python-pyportmidi