summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-04-09 17:05:41 -0400
committerLeo Famulari <leo@famulari.name>2018-04-24 13:07:07 -0400
commit3f1574434965e1b8bd519380121325a8f5e47216 (patch)
tree9d022e28ba256e0b1307dcb3f069b0eb2ac3ce62 /gnu
parent3f0ec617f59bd340d2930ff210e4c3d370c7223e (diff)
downloadguix-3f1574434965e1b8bd519380121325a8f5e47216.tar.gz
gnu: go@1.9: Update to 1.9.5 [fixes CVE-2018-7187].
* gnu/packages/golang.scm (go-1.9): Update to 1.9.5.
[arguments]: Disable the 'TestTwoPkgConfigs' test.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 42d8b3f3f0..d25d2fd465 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -214,7 +214,7 @@ in the style of communicating sequential processes (@dfn{CSP}).")
   (package
     (inherit go-1.4)
     (name "go")
-    (version "1.9.4")
+    (version "1.9.5")
     (source
      (origin
        (method url-fetch)
@@ -222,7 +222,7 @@ in the style of communicating sequential processes (@dfn{CSP}).")
                            name version ".src.tar.gz"))
        (sha256
         (base32
-         "01nw8rfvf10naja0wq0kabsm012sbqq76hd4b8c7g28n6ggshwq5"))))
+         "1g4zqhbh1yw3gnb400szzwrdz0k5s3h0h5nc35xgmn5v69zvphpi"))))
     (arguments
      (substitute-keyword-arguments (package-arguments go-1.4)
        ((#:phases phases)
@@ -292,6 +292,7 @@ in the style of communicating sequential processes (@dfn{CSP}).")
                     ("syscall/syscall_unix_test.go" "(.+)(TestPassFD\\(.+)")
                     ("os/exec/exec_test.go" "(.+)(TestExtraFiles/areturn.+)")
                     ("cmd/go/go_test.go" "(.+)(TestCoverageWithCgo.+)")
+                    ("cmd/go/go_test.go" "(.+)(TestTwoPkgConfigs.+)")
                     ("os/exec/exec_test.go" "(.+)(TestOutputStderrCapture.+)")
                     ("os/exec/exec_test.go" "(.+)(TestExtraFiles.+)")
                     ("os/exec/exec_test.go" "(.+)(TestExtraFilesRace.+)")