summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-10-19 23:44:43 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-10-20 00:03:40 +0200
commit40557391ab7e9c21e24f0fb2cc925c0f2b03f4d5 (patch)
tree0eee8cf73326d088a21b8bcf97e299f6fc04a84c /gnu
parent79624befa1a41e0ea237a4654209a1c08524374c (diff)
downloadguix-40557391ab7e9c21e24f0fb2cc925c0f2b03f4d5.tar.gz
gnu: Add texlive-libertine.
* gnu/packages/tex.scm (texlive-libertine): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index f297252de4..b799ef1773 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5353,6 +5353,36 @@ alternative version of the Kurier fonts.  The difference lies in the absence
 of ink traps which typify the Kurier font.")
     (license license:gfl1.0)))
 
+(define-public texlive-libertine
+  (package
+    (inherit (simple-texlive-package
+              "texlive-libertine"
+              (list "/doc/fonts/libertine/"
+
+                    "/fonts/enc/dvips/libertine/"
+                    "/fonts/map/dvips/libertine/"
+                    "/fonts/opentype/public/libertine/"
+                    "/fonts/tfm/public/libertine/"
+                    "/fonts/type1/public/libertine/"
+                    "/fonts/vf/public/libertine/"
+
+                    "/tex/latex/libertine/")
+              (base32
+               "1v2vimpfi0b08sd79dadrck7wkpa0bphiakwyvhjc3ygq9k5bp8k")
+              #:trivial? #t))
+    (home-page "https://www.ctan.org/pkg/libertine")
+    (synopsis "Use Linux Libertine and Biolinum fonts with LaTeX")
+    (description
+     "The package provides the Libertine and Biolinum fonts in both Type 1 and
+OTF styles, together with support macros for their use.  Monospaced and
+display fonts, and the \"keyboard\" set are also included, in OTF style, only.
+The @code{mweights} package is used to manage the selection of font weights.
+The package supersedes both the @code{libertineotf} and the
+@code{libertine-legacy} packages.")
+    (license (list license:gpl2+        ; with font exception
+                   license:silofl1.1
+                   license:lppl))))
+
 (define-public texlive-latex-titlesec
   (package
     (name "texlive-latex-titlesec")