summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-06-18 18:11:24 +0200
committerJulien Lepiller <julien@lepiller.eu>2019-06-22 17:11:37 +0200
commit453365bcf77cd2fa21cc9794f678cf7e333ae9fe (patch)
treecf25b2affc9f921d6af13900ac4e1da2d0f4b972 /gnu
parenta5c86aa0fbb8a9fa7f5e1b79d652df54ff83229c (diff)
downloadguix-453365bcf77cd2fa21cc9794f678cf7e333ae9fe.tar.gz
gnu: Add harmonist-tk.
* gnu/packages/games.scm (harmonist-tk): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index bf3ab94e68..304ef45024 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -7254,6 +7254,26 @@ the game avoids complex inventory management and character building, relying
 on items and player adaptability for character progression.")
     (license license:isc)))
 
+(define-public harmonist-tk
+  (package
+    (inherit harmonist)
+    (name "harmonist-tk")
+    (arguments
+      (append
+        (package-arguments harmonist)
+        `(#:phases
+          (modify-phases %standard-phases
+            (replace 'build
+              (lambda _
+                (invoke "go" "install" "-v" "-x" "--tags" "tk"
+                        "git.tuxfamily.org/harmonist/harmonist")))
+            (replace 'check
+              (lambda _
+                (invoke "go" "test" "--tags" "tk"
+                        "git.tuxfamily.org/harmonist/harmonist")))))))
+    (inputs
+     `(("go-github.com-nsf-gothic" ,go-github.com-nsf-gothic)))))
+
 (define-public drascula
   (package
     (name "drascula")