summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-11-23 22:04:31 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-11-27 09:48:40 +0100
commit49a3fcc13c4efbb543625b50f8156603c9825ec5 (patch)
treefa0cf1b2d86938bc5ac8c683b95093e2f347cc57 /gnu
parent7a146c252835c992e7aa9647d59d2732f78d34d8 (diff)
downloadguix-49a3fcc13c4efbb543625b50f8156603c9825ec5.tar.gz
gnu: perl-encode-detect: Move to alphabetical position.
* gnu/packages/perl.scm (perl-encode-detect): Move variable definition.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm45
1 files changed, 21 insertions, 24 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 5a42cbb354..a7424479b6 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -2322,6 +2322,27 @@ SHA-1 message digest algorithm for use by Perl programs.")
 modules separately and deal with them after the module is done installing.")
     (license (package-license perl))))
 
+(define-public perl-encode-detect
+  (package
+    (name "perl-encode-detect")
+    (version "1.01")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/J/JG/JGMYERS/"
+                           "Encode-Detect-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1wdv9ffgs4xyfh5dnh09dqkmmlbf5m1hxgdgb3qy6v6vlwx8jkc3"))))
+    (build-system perl-build-system)
+    (native-inputs
+     `(("perl-module-build" ,perl-module-build)))
+    (home-page "http://search.cpan.org/dist/Encode-Detect")
+    (synopsis "Detect the encoding of data")
+    (description "This package provides a class @code{Encode::Detect} to detect
+the encoding of data.")
+    (license mpl1.1)))
+
 (define-public perl-env-path
   (package
     (name "perl-env-path")
@@ -7484,27 +7505,3 @@ interface to File::Find::Object.")
   (description "Test::TrailingSpace tests for trailing spaces
 in Perl source files.")
   (license x11)))
-
-(define-public perl-encode-detect
- (package
-  (name "perl-encode-detect")
-  (version "1.01")
-  (source
-    (origin
-      (method url-fetch)
-      (uri (string-append
-             "mirror://cpan/authors/id/J/JG/JGMYERS/Encode-Detect-"
-             version
-             ".tar.gz"))
-      (sha256
-        (base32
-          "1wdv9ffgs4xyfh5dnh09dqkmmlbf5m1hxgdgb3qy6v6vlwx8jkc3"))))
-  (build-system perl-build-system)
-  (inputs
-    `(("perl-module-build" ,perl-module-build)))
-  (home-page
-    "http://search.cpan.org/dist/Encode-Detect")
-  (synopsis
-    "Perl Encode::Encoding subclass that detects the encoding of data")
-  (description "Encode::Detect detects the encoding of data for Perl.")
-  (license mpl1.1)))