summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJohn Darrington <jmd@gnu.org>2017-01-11 21:27:50 +0100
committerJohn Darrington <jmd@gnu.org>2017-01-12 17:40:55 +0100
commit5aae77e44b6a4cc905ad41e32299260458453470 (patch)
treed59b6485d4d8c0afd72405499ac8140108e52f36 /gnu
parent73ae4e69a1abc9008a6986864021c6584eaf4a21 (diff)
downloadguix-5aae77e44b6a4cc905ad41e32299260458453470.tar.gz
gnu: xfd: Remove wrapper.
* gnu/packages/xorg.scm (xfd): Remove wrapper.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xorg.scm12
1 files changed, 1 insertions, 11 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 16eb344d87..45ff4c97ea 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -4015,19 +4015,9 @@ Font Description (XLFD) full name for a font.")
                 "0n97iqqap9wyxjan2n520vh4rrf5bc0apsw2k9py94dqzci258y1"))))
     (build-system gnu-build-system)
     (arguments
-     ;; The same 'app-defaults' problem as with 'xfontsel' package.
-     (let ((app-defaults-dir "/share/X11/app-defaults"))
        `(#:configure-flags
          (list (string-append "--with-appdefaultdir="
-                              %output ,app-defaults-dir))
-         #:phases
-         (modify-phases %standard-phases
-           (add-after 'install 'wrap-xfd
-             (lambda* (#:key outputs #:allow-other-keys)
-               (let ((out (assoc-ref outputs "out")))
-                 (wrap-program (string-append out "/bin/xfd")
-                   `("XAPPLRESDIR" =
-                     (,(string-append out ,app-defaults-dir)))))))))))
+                              %output ,%app-defaults-dir))))
     (inputs
      `(("fontconfig" ,fontconfig)
        ("libx11" ,libx11)