summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2020-11-17 13:22:02 +0100
committerEfraim Flashner <efraim@flashner.co.il>2020-11-18 10:37:43 +0200
commit6a8bac06d38724b4229631534bb0a0ebaf5effa6 (patch)
treeea08455b37f41960bc23994c07432af9b7d7596d /gnu
parent4a75fdc8779791e5ac3adcab56621e627c6d4ba4 (diff)
downloadguix-6a8bac06d38724b4229631534bb0a0ebaf5effa6.tar.gz
gnu: Add python-globber.
* gnu/packages/python-xyz.scm (python-globber): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 18dafe4797..4f849bc395 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18274,6 +18274,31 @@ Features include, but are not limited to:
 @end itemize")
     (license license:expat)))
 
+(define-public python-globber
+  (package
+    (name "python-globber")
+    (version "0.2.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/asharov/globber")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "055xf7ja7zjhxis0ab5fnfsx16fsvr5fvc6mixqybanwxh8sgfjk"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/asharov/globber")
+    (synopsis "Library for string matching with glob patterns")
+    (description
+     "Globber is a Python library for matching file names against glob patterns.
+In contrast to other glob-matching libraries, it matches arbitrary strings and
+doesn't require the matched names to be existing files.  In addition, it
+supports the globstar @code{**} operator to match an arbitrary number of
+path components.")
+    (license license:asl2.0)))
+
 (define-public python-fusepy
   (package
     (name "python-fusepy")