summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorraingloom <raingloom@riseup.net>2020-10-17 20:56:53 +0200
committerJulien Lepiller <julien@lepiller.eu>2020-11-05 18:44:16 +0100
commit6ba1769da137ca34923e229a49a40c1fb32b8125 (patch)
tree1f1b3709b5221e1130cddd50c00e061b2efe2db1 /gnu
parent546ddefc762ced5fa90d812ddb84bd9d08d250c4 (diff)
downloadguix-6ba1769da137ca34923e229a49a40c1fb32b8125.tar.gz
gnu: Add go-github-com-kardianos-minwinsvc.
* gnu/packages/golang.scm (go-github-com-kardianos-minwinsvc): New variable.

Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 66d734a261..82573bd099 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6009,3 +6009,29 @@ JSON data to the machine.")
     (synopsis "Implementation of WireGuard in Go")
     (description "This package is a Go Implementation of WireGuard.")
     (license license:expat)))
+
+(define-public go-github-com-kardianos-minwinsvc
+  (package
+    (name "go-github-com-kardianos-minwinsvc")
+    (version "1.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/kardianos/minwinsvc")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0z941cxymkjcsj3p5l3g4wm2da3smz7iyqk2wbs5y8lmxd4kfzd8"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/kardianos/minwinsvc"))
+    (home-page "https://github.com/kardianos/minwinsvc/")
+    ;; some packages (Yggdrasil) need it to compile
+    ;; it's a tiny package and it's easier to bundle it than to patch it out
+    (synopsis "Minimal windows only service stub for Go")
+    (description "Go programs designed to run from most *nix style operating
+systems can import this package to enable running programs as services without
+modifying them.")
+    (license license:zlib)))