summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-03-18 12:15:24 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-04-11 11:03:27 +0200
commit936e7d67746a2c769c73692949da1f5a1abf94f9 (patch)
tree08dd8fa1add7494456820c25adb9d806c08be984 /gnu
parentce8eeaf7a4889f1d9d367b2adcd91c1f0a668b82 (diff)
downloadguix-936e7d67746a2c769c73692949da1f5a1abf94f9.tar.gz
gnu: Add r-seqlogo.
* gnu/packages/bioinformatics.scm (r-seqlogo): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 500a08b283..8b0132d91a 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -4748,6 +4748,27 @@ annotations for the genome of the model fruit fly Drosophila melanogaster.")
 annotations for the genome of the model mouse Mus musculus.")
     (license license:artistic2.0)))
 
+(define-public r-seqlogo
+  (package
+    (name "r-seqlogo")
+    (version "1.36.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "seqLogo" version))
+       (sha256
+        (base32
+         "0kn1a1nf2j4v9c09vjkz9bmxlln7yhg87bnyrdsxy1m55x56rn5k"))))
+    (properties `((upstream-name . "seqLogo")))
+    (build-system r-build-system)
+    (home-page "http://bioconductor.org/packages/seqLogo")
+    (synopsis "Sequence logos for DNA sequence alignments")
+    (description
+     "seqLogo takes the position weight matrix of a DNA sequence motif and
+plots the corresponding sequence logo as introduced by Schneider and
+Stephens (1990).")
+    (license license:lgpl2.0+)))
+
 (define-public r-qtl
  (package
   (name "r-qtl")