summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-10-06 14:30:19 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-10-06 14:49:29 +0200
commit9bb8a84623355abcedc9b020b5abfd6f2e48ebc9 (patch)
tree6dd63582fe7be389714ca16b70b09170d769eab6 /gnu
parentb343f5d8fdea44ebcf2e8459f4a3b1ce7da07df2 (diff)
downloadguix-9bb8a84623355abcedc9b020b5abfd6f2e48ebc9.tar.gz
gnu: libtsm: Make all inputs native.
* gnu/packages/terminals.scm (libtsm)[inputs]: Move check & libxkbcommon
from here…
[native-inputs]: …to here.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/terminals.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index b851ca3481..4a9970b9fe 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -235,10 +235,9 @@ text-based approach to terminal recording.")
       (arguments
        `(#:configure-flags '("-DBUILD_TESTING=ON")))
       (native-inputs
-       `(("pkg-config" ,pkg-config)))
-      (inputs
-       `(("libxkbcommon" ,libxkbcommon)
-         ("check" ,check)))
+       `(("check" ,check)
+         ("libxkbcommon" ,libxkbcommon) ; for xkbcommon-keysyms.h
+         ("pkg-config" ,pkg-config)))
       (synopsis "Xterm state machine library")
       (description "TSM is a state machine for DEC VT100-VT520 compatible
 terminal emulators.  It tries to support all common standards while keeping