summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-02-18 11:15:11 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-02-18 11:15:11 +0200
commita4c4b47b122347599e33d1ed6358053619de9f7f (patch)
tree73483c573d95be4283cf0d07cd9e7153772d639e /gnu
parent4fe024bea40e070d0f595708e7f53d61f860854d (diff)
downloadguix-a4c4b47b122347599e33d1ed6358053619de9f7f.tar.gz
gnu: rust-owning-ref-0.4: Don't hide package.
* gnu/packages/crates-io.scm (rust-owning-ref-0.4)[arguments]: Add
rust-stable-deref-trait-1.1 to cargo-inputs.
[properties]: Remove field.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 98b92101ae..e4c9dffaca 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -8454,13 +8454,15 @@ under its new name.")
          (base32
           "04zgwy77lin8qz398s6g44467pd6kjhbrlqifkia5rkr47mbi929"))))
     (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-stable-deref-trait" ,rust-stable-deref-trait-1.1))))
     (home-page "https://github.com/Kimundi/owning-ref-rs")
     (synopsis "Create references that carry their owner with them")
     (description
      "This package provides a library for creating references that carry their
 owner with them.  This can sometimes be useful because Rust borrowing rules
 normally prevent moving a type that has been borrowed from.")
-    (properties '((hidden? . #t)))
     (license license:expat)))
 
 (define-public rust-packed-simd-0.3