summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-04-01 23:19:09 +0200
committerLudovic Courtès <ludo@gnu.org>2019-04-01 23:21:02 +0200
commitd6fda4d3d10fc2201a5507009b79733661fff8a0 (patch)
treeee18d1bcbe5a1268e0fc20a9af0f775c0d7d72ee /gnu
parent2472cdec25f440802e2c9b2904dd5a9cfce677b4 (diff)
downloadguix-d6fda4d3d10fc2201a5507009b79733661fff8a0.tar.gz
gnu: gnome-shell: Add dependency on libgnomekbd.
This fixes the "Show keyboard layout" button in the keyboard layout
switcher.

* gnu/packages/gnome.scm (gnome-shell)[arguments]: In
'record-absolute-file-names' phase, record file name of
'gkbd-keyboard-display'.
[inputs]: Add LIBGNOMEKBD.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 477a550943..60d64c18b2 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5770,6 +5770,10 @@ properties, screen resolution, and other GNOME parameters.")
                (("'ibus-daemon'")
                 (string-append "'" (assoc-ref inputs "ibus")
                                "/bin/ibus-daemon'")))
+             (substitute* "js/ui/status/keyboard.js"
+               (("'gkbd-keyboard-display'")
+                (string-append "'" (assoc-ref inputs "libgnomekbd")
+                               "/bin/gkbd-keyboard-display'")))
              #t))
          (replace 'install
            (lambda* (#:key outputs #:allow-other-keys)
@@ -5827,6 +5831,7 @@ properties, screen resolution, and other GNOME parameters.")
        ("ibus" ,ibus)
        ("libcanberra" ,libcanberra)
        ("libcroco" ,libcroco)
+       ("libgnomekbd" ,libgnomekbd)               ;for gkbd-keyboard-display
        ("libgweather" ,libgweather)
        ("libsoup" ,libsoup)
        ("mesa-headers" ,mesa-headers)