summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorBrett Gilio <brettg@gnu.org>2020-11-25 08:28:53 -0600
committerBrett Gilio <brettg@gnu.org>2020-11-25 08:28:53 -0600
commite16fbddf2b1289ec0f4dcd6d625a73ccdbfd0230 (patch)
treee9cd85607d6a3904c5483f2ba52393afbda08e26 /gnu
parent435739ff48ab8eefc2120af23fc296a579308987 (diff)
downloadguix-e16fbddf2b1289ec0f4dcd6d625a73ccdbfd0230.tar.gz
gnu: et: Deprecate package.
* gnu/packages/terminals.scm (et): Deprecate in favor of
eternalterminal.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/terminals.scm29
1 files changed, 1 insertions, 28 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index ff729c4882..c9d57bee67 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -1082,34 +1082,7 @@ while also supporting native scrolling and @command{tmux} control mode
     (license license:asl2.0)))
 
 (define-public et
-  (package
-    (name "et")
-    (version "3.1.0")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/MisterTea/EternalTCP")
-             (commit (string-append "et-v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "1m5caxckn2ihwp9s2pbyh5amxlpwr7yc54q8s0kb10fr52w2vfnm"))))
-    (build-system cmake-build-system)
-    (arguments `(#:tests? #f))
-    (native-inputs
-     `(("pkg-config" ,pkg-config)))
-    (inputs `(("glog" ,glog)
-              ("gflags" ,gflags)
-              ("libsodium" ,libsodium)
-              ("protobuf" ,protobuf)))
-    (synopsis "Remote shell that automatically reconnects")
-    (description
-     "Eternal Terminal (ET) is a remote shell that automatically reconnects
-without interrupting the session.  Unlike SSH sessions, ET sessions will
-survive even network outages and IP changes.  ET uses a custom protocol over
-TCP, not the SSH protocol.")
-    (home-page "https://eternalterminal.dev/")
-    (license license:asl2.0)))
+  (deprecated-package "et" eternalterminal))
 
 (define-public wterm
   (package