summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-23 18:02:54 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-23 18:13:30 +0100
commite253b94dc63d73ed7d26395048bf8f723d55b764 (patch)
tree0426f106d782c35043180106490a3a801fdf5108 /gnu
parent8b89dedc376d4a3526568da43b9dc4c91d9809ab (diff)
downloadguix-e253b94dc63d73ed7d26395048bf8f723d55b764.tar.gz
gnu: Add python-coveralls.
* gnu/packages/python-check.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/python-check.scm58
2 files changed, 59 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 4795e8534c..7500571be8 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -371,6 +371,7 @@ GNU_SYSTEM_MODULES =				\
   %D%/packages/pure.scm				\
   %D%/packages/pv.scm				\
   %D%/packages/python.scm			\
+  %D%/packages/python-check.scm			\
   %D%/packages/python-compression.scm		\
   %D%/packages/python-crypto.scm		\
   %D%/packages/python-web.scm			\
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
new file mode 100644
index 0000000000..2a5dbaeb30
--- /dev/null
+++ b/gnu/packages/python-check.scm
@@ -0,0 +1,58 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages python-check)
+  #:use-module (gnu packages)
+  #:use-module (gnu packages check)
+  #:use-module (gnu packages python-web)
+  #:use-module (gnu packages python-xyz)
+  #:use-module (guix utils)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix build-system python))
+
+(define-public python-coveralls
+  (package
+    (name "python-coveralls")
+    (version "1.5.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "coveralls" version))
+       (sha256
+        (base32
+         "0vfdny96gcq05qk5wxdbfxfaaprdk7c9q2pqvg7ac5l9sf48wqxb"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-coverage" ,python-coverage)
+       ("python-docopt" ,python-docopt)
+       ("python-pyyaml" ,python-pyyaml)
+       ("python-requests" ,python-requests)
+       ("python-sh" ,python-sh)
+       ("python-urllib3" ,python-urllib3)))
+    (native-inputs
+     `(("python-mock" ,python-mock)
+       ("python-pytest" ,python-pytest)))
+    (home-page "https://github.com/coveralls-clients/coveralls-python")
+    (synopsis "Show coverage stats online via coveralls.io")
+    (description
+     "Coveralls.io is a service for publishing code coverage statistics online.
+This package provides seamless integration with coverage.py (and thus pytest,
+nosetests, etc...) in Python projects.")
+    (license license:expat)))