summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2016-09-21 11:49:32 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-09-21 11:54:15 +1000
commite2ab5a09048e648e6128ad173df3ece8a673c9a3 (patch)
treea3c775900520808564dc60568d349c61514bdaa4 /gnu
parentf75bb2c3f29ed8ac2b292842e0c3deee054553d9 (diff)
downloadguix-e2ab5a09048e648e6128ad173df3ece8a673c9a3.tar.gz
gnu: python-click: Hardlink path to 'locale'.
* gnu/packages/python.scm (python-click, python2-click)[arguments]: New
field.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 65e6389708..af5da9beeb 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2307,6 +2307,17 @@ is used by the Requests library to verify HTTPS requests.")
         (base32
          "1sggipyz52crrybwbr9xvwxd4aqigvplf53k9w3ygxmzivd1jsnc"))))
     (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'fix-paths
+           (lambda* (#:key inputs #:allow-other-keys)
+             (let ((glibc (assoc-ref inputs ,(if (%current-target-system)
+                                                 "cross-libc" "libc"))))
+               (substitute* "click/_unicodefun.py"
+                 (("'locale'")
+                  (string-append "'" glibc "/bin/locale'"))))
+             #t)))))
     (native-inputs
      `(("python-setuptools" ,python-setuptools)))
     (home-page "http://click.pocoo.org")