summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-09-13 20:19:57 +0000
committerRicardo Wurmus <rekado@elephly.net>2016-09-21 21:28:52 +0200
commitf7fe5f7a3e26676657265e98073b9914baf615f1 (patch)
treee95e519125e65285881f60ba8556371f51ad2993 /gnu
parent171091a87496d816658f82ff7c889eb14e2ecb19 (diff)
downloadguix-f7fe5f7a3e26676657265e98073b9914baf615f1.tar.gz
gnu: femtolisp: Remove custom "patch-makefile" phase.
* gnu/packages/lisp.scm (femtolisp)[arguments]: Remove
"patch-makefile" phase; specify test target; build "release"
target instead of "default".
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp.scm12
1 files changed, 2 insertions, 10 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 3461de41f6..d1180a7d6d 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -503,19 +503,11 @@ the InterLisp Standard.")
                   "04rnwllxnl86zw8c6pwxznn49bvkvh0f1lfliy085vjzvlq3rgja"))))
       (build-system gnu-build-system)
       (arguments
-       `(#:make-flags '("CC=gcc")
-         #:tests? #f ; No make check
+       `(#:make-flags '("CC=gcc" "release")
+         #:test-target "test"
          #:phases
          (modify-phases %standard-phases
            (delete 'configure) ; No configure script
-           ;; We have to remove the 'test phase because it requires
-           ;; the flisp binary to be present. Instead we run
-           ;; bootstrap.sh after the 'install phase.
-           (add-before 'build 'patch-makefile
-             (lambda _
-               (substitute* "Makefile"
-                 (("default: release test") "default: release"))
-               #t))
            (replace 'install ; Makefile has no 'install phase
             (lambda* (#:key outputs #:allow-other-keys)
               (let* ((out (assoc-ref outputs "out"))