summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-09-28 21:07:09 +0200
committerLudovic Courtès <ludo@gnu.org>2020-10-12 18:23:47 +0200
commitf848c276f0be22e66b661fe45d60d53fc0013172 (patch)
treefd94b6a961f1e2accfedcaa2a399d90346c56c07 /gnu
parent099d709caf55db44414475c27b7b39f8becb0d64 (diff)
downloadguix-f848c276f0be22e66b661fe45d60d53fc0013172.tar.gz
gnu: gcc-toolchain: Add 'GUIX_LOCPATH' to the search paths.
This allows 'gcc-toolchain' to be used as a drop-in replacement for the
default tool chain through '--with-toolchain=gcc-toolchain'.

* gnu/packages/commencement.scm (make-gcc-toolchain)[native-search-paths]
[search-paths]: Append LIBC's search paths.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/commencement.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 4041d5bb89..0938bc3d46 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -3856,8 +3856,12 @@ COREUTILS-FINAL vs. COREUTILS, etc."
                                                      "libc-static")))
                        #t))))
 
-      (native-search-paths (package-native-search-paths gcc))
-      (search-paths (package-search-paths gcc))
+      (native-search-paths
+       (append (package-native-search-paths gcc)
+               (package-native-search-paths libc))) ;GUIX_LOCPATH
+      (search-paths
+       (append (package-search-paths gcc)
+               (package-search-paths libc)))
 
       (license (package-license gcc))
       (synopsis "Complete GCC tool chain for C/C++ development")