summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-02-17 12:07:06 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-02-17 16:16:36 +0200
commit4f8c551cf367c9b1f83e8b438df4764abaab2d41 (patch)
treef0c4484a36eb9cf241ae9c5ff099be452449a1ed /gnu
parentf7bd9d235eb7d6841ced42e406b896a7384ba7fe (diff)
downloadguix-4f8c551cf367c9b1f83e8b438df4764abaab2d41.tar.gz
gnu: Add ruby-stackprof.
* gnu/packages/ruby.scm (ruby-stackprof): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 28ba7b403e..8dab0b6e1d 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7556,6 +7556,28 @@ navigation capabilities to @code{pry}, using @code{byebug}.")
     (home-page "https://github.com/deivid-rodriguez/pry-byebug")
     (license license:expat)))
 
+(define-public ruby-stackprof
+  (package
+    (name "ruby-stackprof")
+    (version "0.2.16")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (rubygems-uri "stackprof" version))
+        (sha256
+         (base32
+          "147rb66p3n062vc433afqhkd99iazvkrqnghxgh871r62yhha93f"))))
+    (build-system ruby-build-system)
+    (native-inputs
+     `(("ruby-mocha" ,ruby-mocha)
+       ("ruby-rake-compiler" ,ruby-rake-compiler)))
+    (synopsis "Sampling profiler for Ruby code")
+    (description
+     "@code{stackprof} is a fast sampling profiler for Ruby code, with cpu,
+wallclock and object allocation samplers.")
+    (home-page "http://github.com/tmm1/stackprof")
+    (license license:expat)))
+
 (define-public ruby-binding-of-caller
   (package
     (name "ruby-binding-of-caller")