summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorChris Marusich <cmmarusich@gmail.com>2021-01-31 18:45:24 -0800
committerChris Marusich <cmmarusich@gmail.com>2021-03-10 23:01:58 -0800
commit680b20f24c563a67c7fdf2291a3d2ac44749fe47 (patch)
tree7bd3a96880f7b5f172d6775b4f29176cad247412 /gnu
parentc069f8e43354b75fda9bc2002203174d8b18a2db (diff)
downloadguix-680b20f24c563a67c7fdf2291a3d2ac44749fe47.tar.gz
gnu: gcc-boot0: Enable 128-bit long double for POWER9.
* gnu/packages/commencement.scm (gcc-boot0) [#:configure-flags]: Add
--with-long-double-128 when the boot triplet is "powerpc64le-guix-linux-gnu",
instead of "powerpc64le-linux-gnu", which is incorrect.  The actual triplet
used during bootstrapping is "powerpc64le-guix-linux-gnu".
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/commencement.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index b2921a4a48..6fc224f9c8 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -10,6 +10,7 @@
 ;;; Copyright © 2020 Timothy Sample <samplet@ngyro.com>
 ;;; Copyright © 2020 Guy Fleury Iteriteka <gfleury@disroot.org>
 ;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021 Chris Marusich <cmmarusich@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2728,7 +2729,8 @@ exec " gcc "/bin/" program
                            "--disable-shared"
                            "--enable-languages=c,c++"
 
-                           ,@(if (equal? "powerpc64le-linux-gnu" (boot-triplet))
+                           ;; boot-triplet inserts "guix" in the triplet.
+                           ,@(if (equal? "powerpc64le-guix-linux-gnu" (boot-triplet))
                                  ;; On POWER9 (little endian) glibc needs the
                                  ;; 128-bit long double type.
                                  '("--with-long-double-128")