summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-05-10 12:49:42 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-05-10 13:31:02 +0200
commit70debac5f1febe8a811de67d983bd4a8f3ec71f5 (patch)
tree2ec205444a35e683e7f6db7d844544f34fa6e7b8 /gnu
parent5bea832f72b2205af57c716775552490f23b4914 (diff)
downloadguix-70debac5f1febe8a811de67d983bd4a8f3ec71f5.tar.gz
gnu: Add r-enrichr.
* gnu/packages/cran.scm (r-enrichr): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index e91642abd1..564b6fd651 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -14290,3 +14290,27 @@ various explainers that help to understand the link between input variables
 and model output.")
     ;; Any version of the GPL
     (license license:gpl3+)))
+
+(define-public r-enrichr
+  (package
+    (name "r-enrichr")
+    (version "1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "enrichR" version))
+       (sha256
+        (base32
+         "0lfdr45sdyqhvgz8q4qdbk12mpv86d6id665kq6aaslgr8jggfmn"))))
+    (properties `((upstream-name . "enrichR")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-httr" ,r-httr)
+       ("r-rjson" ,r-rjson)))
+    (home-page "https://cran.r-project.org/web/packages/enrichR/")
+    (synopsis "R Interface to Enrichr database for analyzing gene sets")
+    (description
+     "This package provides an R interface to all Enrichr databases, a
+web-based tool for analyzing gene sets and returns any enrichment of common
+annotated biological functions.")
+    (license license:gpl2+)))