summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-03-04 21:31:50 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-03-05 16:12:31 +0100
commit81aa2fa4ae8fda14dd900ca07559f809ab3354b9 (patch)
tree7c206d348ecfbeeffebddb6806630050e851e396 /gnu
parent297531ef58ea91d167dac0474d02a538e8e6bc74 (diff)
downloadguix-81aa2fa4ae8fda14dd900ca07559f809ab3354b9.tar.gz
gnu: php: Update to 7.4.16 [security fixes].
* gnu/packages/php.scm (php): Update to 7.4.16.
[arguments]: Patch failing new test.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/php.scm14
1 files changed, 11 insertions, 3 deletions
diff --git a/gnu/packages/php.scm b/gnu/packages/php.scm
index 46062facee..e93d1122be 100644
--- a/gnu/packages/php.scm
+++ b/gnu/packages/php.scm
@@ -1,7 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2016-2020 Julien Lepiller <julien@lepiller.eu>
 ;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018, 2020, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2019 Oleg Pykhalov <go.wigust@gmail.com>
 ;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
@@ -60,7 +60,7 @@
 (define-public php
   (package
     (name "php")
-    (version "7.4.15")
+    (version "7.4.16")
     (home-page "https://secure.php.net/")
     (source (origin
               (method url-fetch)
@@ -68,7 +68,7 @@
                                   "php-" version ".tar.xz"))
               (sha256
                (base32
-                "1f1wsi2frdbr9a3hvhmk3mmd7cwzf6mwya2akpzkwyygy1jrr1cv"))
+                "12xr7w2mk8ab3igvbpi94ks2xfw2nqga9a6nxs94rvcdz3xcw5hw"))
               (modules '((guix build utils)))
               (snippet
                '(with-directory-excursion "ext"
@@ -327,6 +327,14 @@
                          ;; Expects an empty Array; gets one with " " in it.
                          "ext/pcre/tests/bug80118.phpt"))
 
+             ;; Accomodate two extra openssl errors flanking the expected one:
+             ;; random number generator:RAND_{load,write}_file:Cannot open file
+             ;; This is due to an invalid $HOME, but changing it in the test
+             ;; still prints the first one & changing it globally is overkill.
+             (substitute* "ext/openssl/tests/bug80747.phpt"
+               ((".*error:%s:key size too small.*" match)
+                (string-append "%s\n" match "%s\n")))
+
              ;; Skip tests requiring network access.
              (setenv "SKIP_ONLINE_TESTS" "1")
              ;; Without this variable, 'make test' passes regardless of failures.