summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2019-02-08 18:16:11 -0800
committerDanny Milosavljevic <dannym@scratchpost.org>2019-02-11 10:51:11 +0100
commit8d22f7e31f6fc766af2db845bcd8ea975ba0da6c (patch)
tree4da62ff0e04ec1646bd5ff400437e175c5b8e6c1 /gnu
parenta33633419606bdf787c30f1087756a4fe6716f3b (diff)
downloadguix-8d22f7e31f6fc766af2db845bcd8ea975ba0da6c.tar.gz
gnu: Add python-pymsgbox.
* gnu/packages/python-xyz.scm (python-pymsgbox): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 093a888b8b..183ac56372 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1938,6 +1938,40 @@ easier to build concurrent applications.")
 (define-public python2-pykka
   (package-with-python2 python-pykka))
 
+(define-public python-pymsgbox
+  (package
+    (name "python-pymsgbox")
+    (version "1.0.6")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+              ;; LICENSE.txt is not present on pypi
+              (url "https://github.com/asweigart/PyMsgBox")
+              (commit "55926b55f46caa969c5ddb87990ebea2737bd66f")))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0zy7rjfpwlrd8b64j7jk2lb8m2npc21rnpwakpfvwgl4nxdy80rg"))))
+    (arguments
+     ;; Circular dependency to run tests:
+     ;; Tests need pyautogui, which depends on pymsgbox.
+     '(#:tests? #f))
+    (build-system python-build-system)
+    (home-page "https://github.com/asweigart/PyMsgBox")
+    (synopsis "Python module for JavaScript-like message boxes")
+    (description
+     "PyMsgBox is a simple, cross-platform, pure Python module for
+JavaScript-like message boxes.  Types of dialog boxes include:
+@enumerate
+@item alert
+@item confirm
+@item prompt
+@item password
+@end enumerate
+")
+    (license license:bsd-3)))
+
 (define-public python-pympler
   (package
     (name "python-pympler")