summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorBrian Leung <brian@debian>2019-12-03 17:23:37 -0800
committerBrian Leung <brian@debian>2019-12-07 22:16:31 -0800
commitab9feebb31c85bc7e34a3dbc07c2796ff9ddae3d (patch)
treeba245826caf87684c03effa0fddd56179b4ed67a /gnu
parentadd773c37a10e2c900fcfaff745e095b7fe96fbb (diff)
downloadguix-ab9feebb31c85bc7e34a3dbc07c2796ff9ddae3d.tar.gz
gnu: Add emacs-fullframe.
* gnu/packages/emacs-xyz.scm (emacs-fullframe): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index cab19e9e42..6e158c3653 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -20178,3 +20178,25 @@ top-level header, start the minor mode with @code{org-present}, and page through
 each slide with left/right keys.")
       (home-page "https://github.com/rlister/org-present")
       (license license:gpl2))))
+
+(define-public emacs-fullframe
+  (package
+    (name "emacs-fullframe")
+    (version "0.5.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/tomterl/fullframe.git")
+             (commit version)))
+       (sha256
+        (base32
+         "0m43qnhp6ibsskpjkxc86p3lrjsjc0ndqml3lbd65s79x4x7i3fi"))
+       (file-name (git-file-name name version))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/tomterl/fullframe")
+    (synopsis "Generalized automatic execution in a single frame")
+    (description "This library provides helpers for single-window-per-frame
+execution of buffer-exposing commands.")
+    (license license:gpl3+)))
+