summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-10-11 20:29:02 -0400
committerLeo Famulari <leo@famulari.name>2017-10-12 21:22:55 -0400
commitae8c7774c06f6cdac7915627fd0b81e828c3e6d0 (patch)
treea31cef88890c7688fce5296c3c1ec70783e5c1ed /gnu
parent4c3cc9496c1f98bc5160ea7a7548664c15aa64dc (diff)
downloadguix-ae8c7774c06f6cdac7915627fd0b81e828c3e6d0.tar.gz
gnu: Add go-golang-org-x-text-union.
* gnu/packages/syncthing.scm (go-golang-org-x-text-union): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/syncthing.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 2ac39d1f17..43aeaac0e7 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -1283,6 +1283,31 @@ for low-level interaction with the operating system.")
       (home-page "https://go.googlesource.com/sys")
       (license bsd-3))))
 
+(define* (go-golang-org-x-text-union #:optional
+                                  (packages (list go-golang-org-x-text-transform
+                                                  go-golang-org-x-text-unicode-norm)))
+  (package
+    (name "go-golang-org-x-text")
+    (version (package-version go-golang-org-x-text-transform))
+    (source #f)
+    (build-system trivial-build-system)
+    (arguments
+     '(#:modules ((guix build union))
+       #:builder (begin
+                   (use-modules (ice-9 match)
+                                (guix build union))
+                   (match %build-inputs
+                     (((names . directories) ...)
+                      (union-build (assoc-ref %outputs "out")
+                                   directories))))))
+    (inputs (map (lambda (package)
+                   (list (package-name package) package))
+                 packages))
+    (synopsis "Union of the Go text libraries")
+    (description "A union of the Golang text libraries.")
+    (home-page (package-home-page go-golang-org-x-text-transform))
+    (license (package-license go-golang-org-x-text-transform))))
+
 (define-public go-golang-org-x-text-transform
   (let ((commit "f4b4367115ec2de254587813edaa901bc1c723a8")
         (revision "0"))