summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-17 19:16:13 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-17 19:16:13 +0100
commitc651aa533c6bd9bf2a30f294e53cbb9eb4aafa5e (patch)
tree6cc7fe2f248f441a9f3d86aea79796d62e4060fc /gnu
parentd9dd91034716ed5656628085cc1e6dea98b783cb (diff)
downloadguix-c651aa533c6bd9bf2a30f294e53cbb9eb4aafa5e.tar.gz
gnu: Add emacs-dap-mode.
* gnu/packages/emacs-xyz.scm (emacs-dap-mode): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0fa1d6e520..0364231e1f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -21605,6 +21605,34 @@ Projectile.")
 and implementation of treeview controls using treemacs as a tree renderer.")
     (license license:gpl3+)))
 
+(define-public emacs-dap-mode
+  (package
+    (name "emacs-dap-mode")
+    (version "0.6")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/emacs-lsp/dap-mode")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1d4hdydfk86d4slibigyhwng8wx3vzyap8hp5iv0h7wr6868m4iv"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-bui" ,emacs-bui)
+       ("emacs-lsp-mode" ,emacs-lsp-mode)
+       ("emacs-posframe" ,emacs-posframe)
+       ("emacs-lsp-treemacs" ,emacs-lsp-treemacs)))
+    (home-page "https://emacs-lsp.github.io/dap-mode")
+    (synopsis "Emacs client/library for Debug Adapter Protocol ")
+    (description
+     "Dap mode is an Emacs client/library for Debug Adapter
+Protocol (DAP), a wire protocol for communication between client and
+debug server.  It is similar to the LSP but provides integration with
+Debug server.")
+    (license license:gpl3+)))
+
 (define-public emacs-pfuture
   (package
     (name "emacs-pfuture")