summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-02-01 18:47:25 +0100
committerJulien Lepiller <julien@lepiller.eu>2019-02-05 22:34:09 +0100
commitf4304c1d6c3a89b0b01104964b06b95a1e4e94cf (patch)
treeca0933ebb40de0117733b1a2a3119f03835eb777 /gnu
parent4e4e5fb1dfed2c9c55486e09bb4a39e7e40aee1a (diff)
downloadguix-f4304c1d6c3a89b0b01104964b06b95a1e4e94cf.tar.gz
gnu: Add ocaml-ppx-js-style.
* gnu/packages/ocaml.scm (ocaml-ppx-js-style): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 20766790f0..c07585743c 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5785,3 +5785,32 @@ to Cram.  Expect-tests mimics the existing inline tests framework with the
 output-generating code, interleaved with @code{%expect} extension expressions
 to denote the expected output.")
     (license license:asl2.0)))
+
+(define-public ocaml-ppx-js-style
+  (package
+    (name "ocaml-ppx-js-style")
+    (version "0.11.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://ocaml.janestreet.com/ocaml-core/v"
+                                  (version-major+minor version)
+                                  "/files/ppx_js_style-v" version ".tar.gz"))
+              (sha256
+               (base32
+                "0z3fc55jdjhhsblla6z4fqc13kljpcz29q79rvs5h2vsraqrldr2"))))
+    (build-system dune-build-system)
+    (arguments
+     ;; No tests
+     `(#:tests? #f))
+    (propagated-inputs
+      `(("ocaml-base" ,ocaml-base)
+        ("ocaml-migrate-parsetree" ,ocaml-migrate-parsetree)
+        ("ocaml-octavius" ,ocaml-octavius)
+        ("ocaml-ppxlib" ,ocaml-ppxlib)))
+    (properties `((upstream-name . "ppx_js_style")))
+    (home-page "https://github.com/janestreet/ppx_js_style")
+    (synopsis "Code style checker for Jane Street Packages")
+    (description "This packages is a no-op ppx rewriter.  It is used as a
+@code{lint} tool to enforce some coding conventions across all Jane Street
+packages.")
+    (license license:asl2.0)))