summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-10-27 19:23:09 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-10-27 19:23:09 +0300
commit204bac09f9121429db4ba618a6c079de60b0f4bd (patch)
treef1104920c067267503602d02e6cd2972d25f641b /gnu
parentce6b5eb701bdf035398d4f834f6d18c13b610e0d (diff)
downloadguix-204bac09f9121429db4ba618a6c079de60b0f4bd.tar.gz
gnu: python-watchgod: Update to 0.7.
* gnu/packages/python-xyz.scm (python-watchgod): Update to 0.7.
[native-inputs]: Remove python-docutils, python-flake8, python-isort,
python-pycodestyle, python-pyflakes, and python-pytest-aiohttp; add
python-pytest-asyncio.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm11
1 files changed, 3 insertions, 8 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index da3402477e..b2aaef14d3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24324,7 +24324,7 @@ but portable.")
 (define-public python-watchgod
   (package
     (name "python-watchgod")
-    (version "0.6")
+    (version "0.7")
     (source
      (origin
        ;; There are no tests in the PyPI tarball.
@@ -24334,7 +24334,7 @@ but portable.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1lqx44wkryakgpyqj3m0hsz61bqr07vc7smgzh188374hwvscp66"))))
+        (base32 "1w2xsidwp9n4giqhja0bzw7rwrh01db0kdxf2n54mv3dkx545jpq"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -24345,15 +24345,10 @@ but portable.")
                (invoke "pytest" "-vv")))))))
     (native-inputs
      `(("python-coverage" ,python-coverage)
-       ("python-docutils" ,python-docutils)
-       ("python-flake8" ,python-flake8)
-       ("python-isort" ,python-isort)
-       ("python-pycodestyle" ,python-pycodestyle)
-       ("python-pyflakes" ,python-pyflakes)
        ("python-pygments" ,python-pygments)
        ("python-pytest" ,python-pytest)
+       ("python-pytest-asyncio" ,python-pytest-asyncio)
        ("python-pytest-cov" ,python-pytest-cov)
-       ("python-pytest-aiohttp" ,python-pytest-aiohttp)
        ("python-pytest-mock" ,python-pytest-mock)
        ("python-pytest-sugar" ,python-pytest-sugar)
        ("python-pytest-toolbox" ,python-pytest-toolbox)))