summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorBrendan Tildesley <mail@brendan.scot>2020-08-31 21:51:34 +1000
committerLudovic Courtès <ludo@gnu.org>2020-12-18 16:13:40 +0100
commit2be6323080cc0f298c38a781b596f90fd8803430 (patch)
treead7c39604b03fac46b2f673e340e36a254842254 /gnu
parent8837bb2d3143ba530fe8b8e7872269a4c85fa544 (diff)
downloadguix-2be6323080cc0f298c38a781b596f90fd8803430.tar.gz
gnu: chez-scheme: Patch more hard-coded paths.
* gnu/packages/chez.scm (chez-scheme): Patch out some /bin/rm and
/bin/echo references.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/chez.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index 5805c20b60..eac556c4d0 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -151,11 +151,14 @@
                                     "|stex\\.stex"
                                     "|newrelease"
                                     "|workarea"
+                                    "|unix\\.ms"
+                                    "|^6\\.ms"
                                     ;;"|[a-zA-Z0-9.]+\\.ms" ; guile can't read
                                     ")"))
                  (("/bin/rm") (which "rm"))
                  (("/bin/ln") (which "ln"))
-                 (("/bin/cp") (which "cp")))
+                 (("/bin/cp") (which "cp"))
+                 (("/bin/echo") (which "echo")))
                (substitute* "makefiles/installsh"
                  (("/bin/true") (which "true")))
                (substitute* "stex/Makefile"