summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-05-04 15:09:34 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-05-04 15:17:17 +0200
commit2f99cf3f38f656ec94bc3517208cabb0350f6cfe (patch)
tree5ee1f32a7ef32a88b83ec754bed5dd9978e6f5cd /gnu
parent8e92a174311e939514e73dd08b70f828fbf63734 (diff)
downloadguix-2f99cf3f38f656ec94bc3517208cabb0350f6cfe.tar.gz
gnu: Add texlive-storebox.
* gnu/packages/tex.scm (texlive-storebox): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index fd7272f88c..9c00fc6579 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -8267,6 +8267,35 @@ the conditional @code{\\ifoddpageoronside} is provided which is also true in
 @code{oneside} mode where all pages use the odd page layout.")
       (license license:lppl1.3))))
 
+(define-public texlive-storebox
+  (let ((template (simple-texlive-package
+                   "texlive-storebox"
+                   (list "/source/latex/storebox/")
+                   (base32
+                    "1ybpjfrria57fwvr9kriiw6y76ivwvsyb6ayp0bi750smsv8k5n1"))))
+    (package
+      (inherit template)
+      (arguments
+       (substitute-keyword-arguments (package-arguments template)
+         ((#:tex-directory _ '())
+          "latex/storebox")
+         ((#:build-targets _ '())
+          ''("storebox.ins"))
+         ((#:phases phases)
+          `(modify-phases ,phases
+             (add-after 'unpack 'chdir
+               (lambda _ (chdir "source/latex/storebox")))))))
+      (native-inputs
+       `(("texlive-ydoc" ,texlive-ydoc)))
+      (home-page "https://www.ctan.org/pkg/storebox")
+      (synopsis "Storing information for reuse")
+      (description "The package provides \"store boxes\" whose user interface
+matches that of normal LaTeX \"save boxes\", except that the content of a
+store box appears at most once in the output PDF file, however often it is
+used.  The present version of the package supports pdfLaTeX and LuaLaTeX; when
+DVI is output, store boxes behave the same as save boxes.")
+      (license license:lppl1.3))))
+
 (define-public texlive-kastrup
   (package
     (name "texlive-kastrup")