summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLéo Le Bouter <lle-bout@zaclys.net>2021-02-04 23:33:53 +0100
committer宋文武 <iyzsong@member.fsf.org>2021-02-11 17:18:15 +0800
commit4767ab4bf6ba44439a52b9c403128e86bd6234d5 (patch)
tree20e07a699c96436364d8ed1c2d9c60ff629385dc /gnu
parent988ac06ce8cf9b1760094e0e2ff23960355d07eb (diff)
downloadguix-4767ab4bf6ba44439a52b9c403128e86bd6234d5.tar.gz
gnu: miredo: Fix creation of .pid file.
* gnu/packages/networking.scm (miredo)[arguments]: Add "--localstatedir=/var"
to #:configure-flags and add 'do-not-create-/run phase to #:phases to remove
code that tries to create a directory inside "@localstatedir@" during install.

Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/networking.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index abaab60f31..5e0022ac76 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -700,8 +700,16 @@ or, more generally, MAC addresses of the same category of hardware.")
                 "0j9ilig570snbmj48230hf7ms8kvcwi2wblycqrmhh85lksd49ps"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:phases
+     '(#:configure-flags
+       (list "--localstatedir=/var")
+       #:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'do-not-create-/run
+           (lambda _
+             (substitute* (find-files "src" "Makefile.*")
+               (("^.+install_sh.+/run.+$")
+                "\ttrue"))
+             #t))
          (add-after 'unpack 'patch-iproute2
            (lambda* (#:key inputs #:allow-other-keys)
              (let* ((iproute (assoc-ref inputs "iproute"))