summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-10-23 23:32:56 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-10-23 23:33:08 +0200
commit82924c19530b386f1eb972fc84aa535365c3c012 (patch)
tree54464030ba984edf3bb8bbc6140dd0d472c05003 /gnu
parent6b0b6bb4a21afab9720df9f04d531af9ab804673 (diff)
downloadguix-82924c19530b386f1eb972fc84aa535365c3c012.tar.gz
gnu: asciinema: Update to 2.1.0.
* gnu/packages/terminals.scm (asciinema): Update to 2.1.0.
[arguments]: Don't explicitly return #t from phases.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/terminals.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 637ddb7264..d606bf4bea 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -199,7 +199,7 @@ insert mode and command mode where keybindings have different functions.")
 (define-public asciinema
   (package
     (name "asciinema")
-    (version "2.0.2")
+    (version "2.1.0")
     (source
      (origin
        (method git-fetch)
@@ -208,8 +208,7 @@ insert mode and command mode where keybindings have different functions.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32
-         "1a2pysxnp6icyd08mgf66xr6f6j0irnfxdpf3fmzcz31ix7l9kc4"))))
+        (base32 "1alcz018jrrpasrmgs8nw775a6pf62xq2xgs54c4mb396prdqy4x"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -219,8 +218,7 @@ insert mode and command mode where keybindings have different functions.")
              (let ((ncurses (assoc-ref inputs "ncurses")))
                (substitute* "asciinema/term.py"
                  (("'tput'")
-                  (string-append "'" ncurses "/bin/tput'"))))
-             #t))
+                  (string-append "'" ncurses "/bin/tput'"))))))
          (replace 'check
            (lambda _ (invoke "nosetests" "-v"))))))
     (inputs `(("ncurses" ,ncurses)))