summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-02-12 23:25:31 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-02-13 09:37:52 +0100
commit89f14b19936e0446927a5a5aec56f30ebba715fa (patch)
treebdc60469ce142ebb0bbcae1089f7d89aa2c29fd6 /gnu
parent00e560fa0fcee2aaacd9c7ffeb1d37179dacafaa (diff)
downloadguix-89f14b19936e0446927a5a5aec56f30ebba715fa.tar.gz
gnu: Add texlive-babel/fixed.
* gnu/packages/tex.scm (texlive-babel/fixed): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c1ec591096..d0f634ad01 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4157,6 +4157,29 @@ what has to be done for each language.  Users of XeTeX are advised to use the
 polyglossia package rather than Babel.")
       (license license:lppl1.3+))))
 
+(define-public texlive-babel/fixed
+  (package
+    (inherit texlive-babel)
+    (name "texlive-babel-fixed")
+    (arguments
+     (substitute-keyword-arguments (package-arguments texlive-babel)
+       ((#:phases phases)
+        `(modify-phases ,phases
+           (add-before 'copy-files 'unchdir
+             (lambda _
+               (chdir "../../..")))
+           (add-after 'copy-files 'delete-extra-files
+             (lambda* (#:key outputs #:allow-other-keys)
+               (delete-file-recursively
+                (string-append (assoc-ref outputs "out")
+                               "/share/texmf-dist/source/latex/babel/build"))
+               (delete-file
+                (string-append (assoc-ref outputs "out")
+                               "/share/texmf-dist/tex/generic/babel/bbind.ist"))
+               (delete-file
+                (string-append (assoc-ref outputs "out")
+                               "/share/texmf-dist/tex/generic/babel/bbglo.ist"))))))))))
+
 (define-deprecated-package texlive-latex-babel texlive-babel)
 
 (define-public texlive-generic-babel-english