summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:02 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:25 +0200
commit9d4c16350ef287159455c326ce2c777f36e70763 (patch)
treedd2718759abc235b4390d0e59a46c4db7951e8c2 /gnu
parent80b771fb760b200706553b3c1fede40a7718f33d (diff)
downloadguix-9d4c16350ef287159455c326ce2c777f36e70763.tar.gz
gnu: Add trytond-account-eu.
* gnu/packages/tryton.scm (trytond-account-eu): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tryton.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 9e21bcf54a..8a15050ad8 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -510,6 +510,36 @@ A wizard allows to generate the following AEAT files:
 @end itemize")
     (license license:gpl3+)))
 
+(define-public trytond-account-eu
+  (package
+    (name "trytond-account-eu")
+    (version "6.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_account_eu" version))
+       (sha256
+        (base32 "1x3w7iijkckv20q8lpqb5fnfrvddm130f51mcpnh4hlyx14q1c5i"))))
+    (build-system python-build-system)
+    (arguments (tryton-arguments "account_eu"))
+    (native-inputs `(,@%standard-trytond-native-inputs))
+    (propagated-inputs
+     `(("trytond" ,trytond)
+       ("trytond-account" ,trytond-account)
+       ("trytond-account-invoice" ,trytond-account-invoice)
+       ("trytond-company" ,trytond-company)
+       ("trytond-currency" ,trytond-currency)
+       ("trytond-party" ,trytond-party)))
+    (home-page "https://docs.tryton.org/projects/modules-account-eu")
+    (synopsis "Tryton module for european accounting")
+    (description "This package provides a Tryton module implementing common
+accounting requirements in Europe.  It includes:
+
+@itemize
+@item EC Sales List (ESL)
+@end itemize")
+    (license license:gpl3+)))
+
 (define-public trytond-account-invoice
   (package
     (name "trytond-account-invoice")