summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2021-02-11 11:56:09 +0800
committer宋文武 <iyzsong@member.fsf.org>2021-02-11 11:56:09 +0800
commitc7296465cff593bd3c82c7152e09f4337252ce4d (patch)
tree31880bf03aa65a32cc5d101933a4f435130ef552 /gnu
parent6fbefd03f0433ed4777ffd041746e32535ccc69f (diff)
downloadguix-c7296465cff593bd3c82c7152e09f4337252ce4d.tar.gz
gnu: hedgewars: Fix build.
Fixes <https://issues.guix.gnu.org/46398>.

* gnu/packages/games.scm (hedgewars)[arguments]<#:phases>: Add the missing
"#include <QPainterPath>".
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index efa6d24d8f..bf6b79370a 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -9213,6 +9213,12 @@ play with up to four players simultaneously.  It has network support.")
                                "-Dhaskell_flags=-dynamic;-fPIC")
        #:phases
        (modify-phases %standard-phases
+         (add-before 'configure 'fix-sources
+           (lambda _
+             ;; Fix a missing 'include'.
+             (substitute* "QTfrontend/ui/page/pagegamestats.cpp"
+               (("#include <QSizePolicy>")
+                "#include <QSizePolicy>\n#include <QPainterPath>"))))
          (replace 'check
            (lambda _ (invoke "ctest")))
          (add-after 'install 'install-icon