summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLaFreniere, Joseph <joseph@lafreniere.xyz>2019-05-12 10:46:40 -0500
committerLudovic Courtès <ludo@gnu.org>2019-05-14 12:11:05 +0200
commitdcc3d4030fcdc83f10220a061f4b7e306a99a439 (patch)
tree8ac5debf47f98126960387d233683180206cd539 /gnu
parentef250707d3303d58ae00fe8f461701e7fa788d8a (diff)
downloadguix-dcc3d4030fcdc83f10220a061f4b7e306a99a439.tar.gz
gnu: Add emacs-evil-cleverparens
* gnu/packages/emacs-xyz.scm (emacs-evil-cleverparens): New
  variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2ba9108f37..c7883e3507 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -46,6 +46,7 @@
 ;;; Copyright © 2019 Brian Leung <bkleung89@gmail.com>
 ;;; Copyright © 2019 mikadoZero <mikadozero@yandex.com>
 ;;; Copyright © 2019 Gabriel Hondet <gabrielhondet@gmail.com>
+;;; Copyright © 2019 LaFreniere, Joseph <joseph@lafreniere.xyz>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -15588,3 +15589,30 @@ programs and evaluate embedded queries.  This mode is focused on the command
 @code{ediprolog-dwim} (Do What I Mean) which is supposed to, depending on the
 context, carry out the appropriate action.")
     (license license:gpl3+)))
+
+(define-public emacs-evil-cleverparens
+  (let ((commit "8c45879d49bfa6d4e414b6c1df700a4a51cbb869")
+        (revision "1"))
+    (package
+      (name "emacs-evil-cleverparens")
+      (version (git-version "2017-07-17" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/luxbock/evil-cleverparens.git")
+                      (commit commit)))
+                (sha256 (base32 "0lhnybpnk4n2yhlcnj9zxn0vi5hpjfaqfhvyfy7ckzz74g8v7iyw"))
+                (file-name (git-file-name name version))))
+      (build-system emacs-build-system)
+      (propagated-inputs
+       `(("emacs-evil" ,emacs-evil)
+         ("emacs-paredit" ,emacs-paredit)
+         ("emacs-smartparens" ,emacs-smartparens)))
+      (home-page "https://github.com/luxbock/evil-cleverparens")
+      (synopsis "Emacs modal editing optimized for editing Lisp")
+      (description "@code{evil-cleverparens} remaps Evil keybindings to allow
+modal editing with screwing up the structure of Lisp code.  Alternatives for
+verb commands which would are normally destructive (such as deletion) are
+provided.  Those alternative commands are and bound by default to their
+corresponding Evil keys.")
+      (license license:expat))))