summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-02-11 00:52:47 +0100
committerMarius Bakke <marius@gnu.org>2022-02-11 23:54:30 +0100
commite2c8868301eddea8d5a7089bb606665ace294c70 (patch)
tree21f82f73e67afce18bffcb3ae4199be2ba718d4b /gnu
parent9b0abb52acb8d2ea4d5c25129af34bdd85f99c2a (diff)
downloadguix-e2c8868301eddea8d5a7089bb606665ace294c70.tar.gz
gnu: re2: Update to 2022-02-01.
* gnu/packages/regex.scm (re2): Update to 2022-02-01.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/regex.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/regex.scm b/gnu/packages/regex.scm
index d37663bf5b..662bf435db 100644
--- a/gnu/packages/regex.scm
+++ b/gnu/packages/regex.scm
@@ -31,7 +31,7 @@
 (define-public re2
    (package
      (name "re2")
-     (version "2020-11-01")
+     (version "2022-02-01")
      (home-page "https://github.com/google/re2")
      (source (origin
                (method git-fetch)
@@ -39,7 +39,7 @@
                (file-name (git-file-name name version))
                (sha256
                 (base32
-                 "0ii51fpp6fn51x4qyd99sy4r122s8ayh4x1srwhhijxlh8mzla5k"))))
+                 "1gzdqy5a0ln9rwd8kmwbgis6qin63hapicwb35xkbnj3y84jj6yx"))))
      (build-system gnu-build-system)
      (arguments
       `(#:modules ((guix build gnu-build-system)
@@ -64,8 +64,7 @@
             (lambda* (#:key outputs #:allow-other-keys)
               ;; No make target for shared-only; delete the static version.
               (delete-file (string-append (assoc-ref outputs "out")
-                                          "/lib/libre2.a"))
-              #t)))))
+                                          "/lib/libre2.a")))))))
      (synopsis "Fast, safe, thread-friendly regular expression engine")
      (description "RE2 is a fast, safe, thread-friendly alternative to
 backtracking regular expression engines like those used in PCRE, Perl and