summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2021-09-15 18:03:02 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2021-09-15 18:03:02 +0200
commit00e3a3a177b9e0369a7b4b3d179e8d76e2764082 (patch)
treef5a278a0c9c082e53fd62e387c82efca933f693d /gnu
parent68f51bf5363f06e118334457b591d1f310a7dc48 (diff)
downloadguix-00e3a3a177b9e0369a7b4b3d179e8d76e2764082.tar.gz
gnu: xpadneo: Copy udev rules to /lib.
This makes xpadneo place its udev rules in the place where udev-service-type
looks for them.

* gnu/packages/linux.scm (xpadneo): Copy udev rules to /lib instead of /etc.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index b0ad62eff9..46c9f817a8 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1606,8 +1606,10 @@ application by hooking GStreamer into the loopback device.")
              (let ((out (assoc-ref outputs "out")))
                (copy-recursively "hid-xpadneo/etc-modprobe.d"
                                  (string-append out "/etc/modprobe.d"))
+               ;; udev-service-type takes its rules from /lib rather than
+               ;; /etc, so copy it there instead
                (copy-recursively "hid-xpadneo/etc-udev-rules.d"
-                                 (string-append out "/etc/udev/rules.d"))))))))
+                                 (string-append out "/lib/udev/rules.d"))))))))
     (home-page "https://atar-axis.github.io/xpadneo/")
     (synopsis "Xbox One Wireless Controller driver")
     (description