summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-01-25 23:46:53 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-01-26 08:37:57 +0100
commit011db003ce43bf5dca41e5512ba07a42c77cb9ae (patch)
treec7ccdd59f17d51f654207c43eeb9d48ba5878ead /gnu
parent070b8a893febd6e7d8b2b7c8c4dcebacf7845aa9 (diff)
downloadguix-011db003ce43bf5dca41e5512ba07a42c77cb9ae.tar.gz
gnu: nyacc: Update to 1.06.5.
* gnu/packages/mes.scm (nyacc): Update to 1.06.5.
[source]: Simplify snippet.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/mes.scm14
1 files changed, 6 insertions, 8 deletions
diff --git a/gnu/packages/mes.scm b/gnu/packages/mes.scm
index 07e63384ff..87c933d9ea 100644
--- a/gnu/packages/mes.scm
+++ b/gnu/packages/mes.scm
@@ -98,22 +98,20 @@ extensive examples, including parsers for the Javascript and C99 languages.")
 (define-public nyacc
   (package
     (inherit nyacc-0.99)
-    (version "1.05.1")
+    (version "1.06.5")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://savannah/nyacc/nyacc-"
                                   version ".tar.gz"))
               (sha256
                (base32
-                "1ck3gyzln5dhamp317nv3waych12mczj05dm4wdblij6ab0l4863"))
+                "1fbzz9bm4mkz4j40l2z02zjlbqj82dmv2ayz83zl3j8gj6z3lpdg"))
               (modules '((guix build utils)))
               (snippet
-               '(begin
-                  (substitute* "configure"
-                    (("GUILE_GLOBAL_SITE=\\$prefix.*")
-                     "GUILE_GLOBAL_SITE=\
-$prefix/share/guile/site/$GUILE_EFFECTIVE_VERSION\n"))
-                  #t))))
+               '(substitute* "configure"
+                  (("GUILE_GLOBAL_SITE=\\$prefix.*")
+                   "GUILE_GLOBAL_SITE=\
+$prefix/share/guile/site/$GUILE_EFFECTIVE_VERSION\n")))))
     (inputs (list guile-3.0))
     (description
      "@acronym{NYACC, Not Yet Another Compiler Compiler} is set of Guile modules