summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-03-02 10:45:30 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-03-02 10:46:56 +0200
commit0f8a646e03c947fec6cdc3966fab2dd8c8f9f98e (patch)
tree64feba0fa745ed95d24b86537ea4325d838c1285 /gnu
parent70487e3ee9e2d6d6833a0559115a034e50aba129 (diff)
downloadguix-0f8a646e03c947fec6cdc3966fab2dd8c8f9f98e.tar.gz
gnu: octave: Update to 6.2.0.
* gnu/packages/maths.scm (octave): Update to 6.2.0.
[source]: Download tar.xz tarball.
[native-inputs]: Remove lzip.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 083c20dad3..6856737bdf 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1928,15 +1928,15 @@ can solve two kinds of problems:
 (define-public octave-cli
   (package
     (name "octave-cli")
-    (version "6.1.0")
+    (version "6.2.0")
     (source
      (origin
       (method url-fetch)
       (uri (string-append "mirror://gnu/octave/octave-"
-                          version ".tar.lz"))
+                          version ".tar.xz"))
       (sha256
        (base32
-        "0355s0pi8603ccs2j08zym3nalgalslxn83s37zq8nkrrkwxrjfk"))))
+        "06id09zspya24gshcwgp039cp35c06150mdlxysawgnbrhj16wkv"))))
     (build-system gnu-build-system)
     (inputs
      `(("alsa-lib" ,alsa-lib)
@@ -1971,8 +1971,7 @@ can solve two kinds of problems:
        ("texinfo" ,texinfo)
        ("zlib" ,zlib)))
     (native-inputs
-     `(("lzip" ,lzip)
-       ("gfortran" ,gfortran)
+     `(("gfortran" ,gfortran)
        ("pkg-config" ,pkg-config)
        ("perl" ,perl)
        ;; The following inputs are not actually used in the build process.