summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-01 11:28:39 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-01 11:39:58 +0100
commit124d76c5c27fd92dd8c1f9cb9cfe241eaf2498ea (patch)
tree9c9268c7e4a031c366ab78d7dd9da2dcc4a64ad9 /gnu
parent38d648655ba36bf4ca02082a256d7d884094f621 (diff)
downloadguix-124d76c5c27fd92dd8c1f9cb9cfe241eaf2498ea.tar.gz
gnu: python2-numpydoc: Update to 0.9.1.
* gnu/packages/python-xyz.scm (python2-numpydoc): Update to 0.9.1; do not
inherit from Python 3 variant.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6b42d15c3d..3fe6a06db5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6087,6 +6087,15 @@ that client code uses to construct the grammar directly in Python code.")
   (let ((base (package-with-python2
                (strip-python2-variant python-numpydoc))))
     (package/inherit base
+      ;; This is the last version to support Python 2
+      (version "0.9.1")
+      (source
+       (origin
+         (method url-fetch)
+         (uri (pypi-uri "numpydoc" version))
+         (sha256
+          (base32
+           "09x6l1a4dcvj7001bvcmcayg1nwqwhaxlwbp6kzj9qrk57lqx3z0"))))
       (propagated-inputs
        `(("python2-jinja2" ,python2-jinja2)
          ,@(package-propagated-inputs base))))))