summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-21 14:23:04 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-21 15:30:09 +0300
commit18f1bd255d72dcd458f9e3a19a6de17fb531a238 (patch)
treed0fc5944ab1ed5d7c435af2e38d0ffc19a36ad35 /gnu
parentba1c2e5b0d698ce6849f63af867d68cb1f8242b5 (diff)
downloadguix-18f1bd255d72dcd458f9e3a19a6de17fb531a238.tar.gz
gnu: python-django-testing: Update to 0.5.0.
* gnu/packages/django.scm (python-django-testing): Update to 0.5.0.
[properties]: Add python2-variant.
(python2-django-testing): Stay at 0.4.6.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/django.scm18
1 files changed, 15 insertions, 3 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index ce23946c90..625e4c0cda 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -1080,14 +1080,14 @@ higher quality while welcoming newcomers.")
 (define-public python-django-tagging
   (package
     (name "python-django-tagging")
-    (version "0.4.6")
+    (version "0.5.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "django-tagging" version))
        (sha256
         (base32
-         "0s7b4v45j783yaxs7rni10k24san0ya77nqz4s7zdf3jhfpk42r1"))))
+         "13afxx30chssclxzd9gqnvwm9qyrdpnlbs6iswdfa18phfj8zmi8"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -1103,10 +1103,22 @@ higher quality while welcoming newcomers.")
     (description "This package provides a generic tagging application for
 Django projects, which allows association of a number of tags with any
 @code{Model} instance and makes retrieval of tags simple.")
+    (properties `((python2-variant . ,(delay python2-django-tagging))))
     (license license:bsd-3)))
 
 (define-public python2-django-tagging
-  (package-with-python2 python-django-tagging))
+  (let ((base (package-with-python2
+                (strip-python2-variant python-django-tagging))))
+    (package
+      (inherit base)
+      (version "0.4.6")
+      (source
+        (origin
+          (method url-fetch)
+          (uri (pypi-uri "django-tagging" version))
+          (sha256
+           (base32
+            "0s7b4v45j783yaxs7rni10k24san0ya77nqz4s7zdf3jhfpk42r1")))))))
 
 (define-public python-djangorestframework
   (package