summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-03-03 11:20:18 -0500
committerLeo Famulari <leo@famulari.name>2021-03-03 12:08:26 -0500
commit1e1549a7a78e135bb16fed6fcc8bb0891f71ba7c (patch)
treee0125546e64209d534a965cf1bdb3fb75328f73b /gnu
parent0bd58ae7ff0d5c3935b0d660819aca4a0493ef8a (diff)
downloadguix-1e1549a7a78e135bb16fed6fcc8bb0891f71ba7c.tar.gz
gnu: certbot, python-acme: Update to 1.12.0.
* gnu/packages/tls.scm (python-acme): Update to 1.12.0.
(certbot): Update to 1.12.0.
[arguments]: Replace the 'build-documentation' phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tls.scm16
1 files changed, 11 insertions, 5 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 775e915534..c6228f7fd2 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -557,13 +557,13 @@ netcat implementation that supports TLS.")
   (package
     (name "python-acme")
     ;; Remember to update the hash of certbot when updating python-acme.
-    (version "1.10.1")
+    (version "1.12.0")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "acme" version))
               (sha256
                (base32
-                "1n1g29f3qzy77xn06dss9nc92wndgm8phgjrvx740sy9xnd5bfzw"))))
+                "1wn2jvkg18z31nd060hfcp2yqvxjxykim2ybgaidv7qfsms38dma"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -579,7 +579,6 @@ netcat implementation that supports TLS.")
                (install-file "docs/_build/texinfo/acme-python.info" info)
                (install-file "docs/_build/man/acme-python.1" man)
                #t))))))
-    ;; TODO: Add optional inputs for testing.
     (native-inputs
      `(("python-mock" ,python-mock)
        ("python-pytest" ,python-pytest)
@@ -614,12 +613,20 @@ netcat implementation that supports TLS.")
               (uri (pypi-uri "certbot" version))
               (sha256
                (base32
-                "1dww9m1a2p3a9vpxs5j29f8cdkqywqb4j70z3cnkpl7017yf77hd"))))
+                "0nfzk6fzyfqy8lgs5lmxfndrdh5c2ljdvzj39rwvgg3r6ivkirsy"))))
     (build-system python-build-system)
     (arguments
      `(,@(substitute-keyword-arguments (package-arguments python-acme)
            ((#:phases phases)
             `(modify-phases ,phases
+             (replace 'build-documentation
+               (lambda _
+                 ;; Fix building the manual page in 1.12.0:
+                 ;; https://github.com/certbot/certbot/issues/8633
+                 ;; TODO Remove the substitution in later releases.
+                 (substitute* "docs/conf.py"
+                   (("'man',") ""))
+             (invoke "make" "-C" "docs" "man" "info")))
               (replace 'install-documentation
                 (lambda* (#:key outputs #:allow-other-keys)
                   (let* ((out (assoc-ref outputs "out"))
@@ -630,7 +637,6 @@ netcat implementation that supports TLS.")
                     (install-file "docs/_build/man/certbot.1" man1)
                     (install-file "docs/_build/man/certbot.7" man7)
                     #t))))))))
-    ;; TODO: Add optional inputs for testing.
     (native-inputs
      `(("python-mock" ,python-mock)
        ("python-pytest" ,python-pytest)