summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-06-08 16:03:30 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-06-08 17:57:25 +0300
commit2ea20cde08f54b009274e4a74079a989d855ec11 (patch)
tree856d87ea63eeba245e5b95fa114f47ff594775e1 /gnu
parent122897542adb927752a6e017cbd3759f7f1d0c41 (diff)
downloadguix-2ea20cde08f54b009274e4a74079a989d855ec11.tar.gz
gnu: Add julia-genericlinearalgebra.
* gnu/packages/julia-xyz.scm (julia-genericlinearalgebra): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/julia-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 98dd379a1c..411d057f4a 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -962,6 +962,37 @@ differentiation (AD).")
      "FuzzyCompletions provides fuzzy completions for a Julia runtime session.")
     (license license:expat)))
 
+(define-public julia-genericlinearalgebra
+  (package
+    (name "julia-genericlinearalgebra")
+    (version "0.2.5")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/JuliaLinearAlgebra/GenericLinearAlgebra.jl")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32 "0ndwypa397z3pwzdgc3s9plaqlqf63g3d4px5pvym5psgr6lnm3l"))))
+    (build-system julia-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'adjust-test-suite
+           (lambda _
+             (substitute* "test/runtests.jl"
+               ((".*lapack.*") "")))))))
+    (native-inputs
+     `(("julia-quaternions" ,julia-quaternions)))
+    (home-page "https://github.com/JuliaLinearAlgebra/GenericLinearAlgebra.jl")
+    (synopsis "Generic numerical linear algebra")
+    (description "The purpose of this package is partly to extend linear algebra
+functionality in base to cover generic element types, e.g. @code{BigFloat} and
+@code{Quaternion}, and partly to be a place to experiment with fast linear
+algebra routines written in Julia (except for optimized BLAS).")
+    (license license:expat)))
+
 (define-public julia-genericschur
   (package
     (name "julia-genericschur")