summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-05 23:35:26 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-02-03 14:27:29 +0100
commit37ac66221ccc2ba0f37dac871b160315a1d78e79 (patch)
tree1b7023101b7cd5196498a04ed1e68761bcd7cddc /gnu
parent5a75e4448aa0b66ef0146ada4621304b3d43c231 (diff)
downloadguix-37ac66221ccc2ba0f37dac871b160315a1d78e79.tar.gz
gnu: Add akonadi-calendar.
* gnu/packages/kde-pim.scm (akonadi-calendar): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/kde-pim.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/kde-pim.scm b/gnu/packages/kde-pim.scm
index 10019103a4..a2db3a24ad 100644
--- a/gnu/packages/kde-pim.scm
+++ b/gnu/packages/kde-pim.scm
@@ -114,6 +114,50 @@ This package contains the Akonadi PIM storage server and associated
 programs.")
     (license license:fdl1.2+)))
 
+(define-public akonadi-calendar
+  (package
+    (name "akonadi-calendar")
+    (version "19.08.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://kde/stable/applications/" version
+                           "/src/akonadi-calendar-" version ".tar.xz"))
+       (sha256
+        (base32 "1550h08i8rjnbd9yrnhd9v3v68ingrag2bdxrbid62qvam0n5ihy"))))
+    (build-system qt-build-system)
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)))
+    (inputs
+     `(("akonadi" ,akonadi)
+       ("akonadi-contacts" ,akonadi-contacts)
+       ("akonadi-mime" ,akonadi-mime)
+       ("boost" ,boost)
+       ("kcalendarcore" ,kcalendarcore)
+       ("kcalutils" ,kcalutils)
+       ("kcodecs" ,kcodecs)
+       ("kcontacts" ,kcontacts)
+       ("kdbusaddons" ,kdbusaddons)
+       ("ki18n" ,ki18n)
+       ("kiconthemes" ,kiconthemes)
+       ("kidentitymanagement" ,kidentitymanagement)
+       ("kio" ,kio)
+       ("kitemmodels" ,kitemmodels)
+       ("kmailtransport" ,kmailtransport)
+       ("kmime" ,kmime)
+       ("kpimtextedit" ,kpimtextedit)
+       ("ksmtp" ,ksmtp)
+       ("ktextwidgets" ,ktextwidgets)
+       ("kwallet" ,kwallet)
+       ("qtbase" ,qtbase)))
+    (arguments
+     `(#:tests? #f))  ;; TODO: 1/1 test fails
+    (home-page "https://api.kde.org/stable/kdepimlibs-apidocs/akonadi/html/")
+    (synopsis "Library providing calendar helpers for Akonadi items")
+    (description "This library manages calendar specific actions for
+collection and item views.")
+    (license license:lgpl2.0+)))
+
 (define-public akonadi-contacts
   (package
     (name "akonadi-contacts")