summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-12-24 04:51:39 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-08 23:51:09 +0100
commit39a7b7206545bd1ccedeccc9ff71ca787baf19a5 (patch)
treead0382f1e167026dbde9792ddc744ebec2bfab59 /gnu
parent1fd71120a7f908ded489f058e2390cd062679ea9 (diff)
downloadguix-39a7b7206545bd1ccedeccc9ff71ca787baf19a5.tar.gz
gnu: python-trezor-agent: Don't use unstable tarball.
* gnu/packages/finance.scm (python-trezor-agent)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/finance.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 8da49a0a87..ce67694cfe 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -590,13 +590,13 @@ Monero GUI client.")
     (version "0.9.4")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/romanz/trezor-agent/archive/v"
-                           version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/romanz/trezor-agent.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
        (sha256
-        (base32
-         "0h8jb147vpjk7mqbl4za0xdh7lblhx07n9dfk80kn2plwnvrry1x"))))
+        (base32 "15aaqk79d9y9nbsfznf2iscz12z5ispcj8kr8v5bc0sqqj2brs12"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -604,7 +604,7 @@ Monero GUI client.")
          (delete 'check)
          (add-after 'install 'check
            (lambda* (#:key outputs inputs #:allow-other-keys)
-             ;; Make installed package available for running the tests
+             ;; Make installed package available for running the tests.
              (add-installed-pythonpath inputs outputs)
              (invoke "py.test"))))))
     (propagated-inputs