summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-16 03:10:51 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-16 15:45:32 +0100
commit44b885656aa1eb1d2dff9ecda35149c71d51b1fe (patch)
tree86f1f202c7882f33976467e9c41f84b2e5c7b36a /gnu
parenta1dc5898fbae4c97a37364e91ae49a55d5641f16 (diff)
downloadguix-44b885656aa1eb1d2dff9ecda35149c71d51b1fe.tar.gz
gnu: python-werkzeug: Update to 1.0.0.
* gnu/packages/python-web.scm (python-werkzeug): Update to 1.0.0.
[source](uri): Capitalize PyPI project name.
[native-inputs]: Add PYTHON-PYTEST-TIMEOUT.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 07c1ceb2db..d1e09fc727 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2783,14 +2783,14 @@ List.  Forked from and using the same API as the publicsuffix package.")
 (define-public python-werkzeug
   (package
     (name "python-werkzeug")
-    (version "0.14.1")
+    (version "1.0.0")
     (source
      (origin
        (method url-fetch)
-       (uri (pypi-uri "werkzeug" version))
+       (uri (pypi-uri "Werkzeug" version))
        (sha256
         (base32
-         "0z2m4snn1vc9518r2vzgdj1nc90kcgi60wijvd29yvcp85ypmzf3"))))
+         "15kh0z61klp62mrc1prka13xsshxn0rsp1j1s2964iw86yisi6qn"))))
     (build-system python-build-system)
     (arguments
      '(#:phases
@@ -2803,7 +2803,8 @@ List.  Forked from and using the same API as the publicsuffix package.")
     (propagated-inputs
      `(("python-requests" ,python-requests)))
     (native-inputs
-     `(("python-pytest" ,python-pytest)))
+     `(("python-pytest" ,python-pytest)
+       ("python-pytest-timeout" ,python-pytest-timeout)))
     (home-page "https://www.palletsprojects.org/p/werkzeug/")
     (synopsis "Utilities for WSGI applications")
     (description "One of the most advanced WSGI utility modules.  It includes a