summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-10-23 10:01:45 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-10-23 10:43:59 +0300
commit4b359565de1022577c8c04ebf1517a6cacfe56ec (patch)
tree30252ff3fd5639c3ccb9caaebb085be1a961f5e5 /gnu
parenta8c86afaa52d3c6237e4085ac4e18ea91c8ba14d (diff)
downloadguix-4b359565de1022577c8c04ebf1517a6cacfe56ec.tar.gz
gnu: Add rust-remove-dir-all-0.5.
* gnu/packages/rust-cbindgen.scm (rust-remove-dir-all-0.5): New hidden
variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/rust-cbindgen.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/rust-cbindgen.scm b/gnu/packages/rust-cbindgen.scm
index fcb57ca130..8a507a0587 100644
--- a/gnu/packages/rust-cbindgen.scm
+++ b/gnu/packages/rust-cbindgen.scm
@@ -586,3 +586,25 @@ system calls.")
      "This package provides a Rust library to access Redox termios functions.")
     (properties '((hidden? . #t)))
     (license license:expat)))
+
+(define rust-remove-dir-all-0.5
+  (package
+    (name "rust-remove-dir-all")
+    (version "0.5.2")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "remove-dir-all" version))
+        (file-name (string-append name "-" version ".crate"))
+        (sha256
+         (base32
+          "0bkrlyg26mgizpiy1yb2hhpgscxcag8r5fnckqsvk25608vzm0sa"))))
+    (build-system cargo-build-system)
+    (home-page "https://github.com/XAMPPRocky/remove_dir_all.git")
+    (synopsis "Implementation of remove_dir_all for Windows")
+    (description
+     "This package provides a safe, reliable implementation of remove_dir_all
+for Windows.")
+    (properties '((hidden? . #t)))
+    (license (list license:asl2.0
+                   license:expat))))