summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-06-09 09:03:46 +0200
committerLudovic Courtès <ludo@gnu.org>2017-06-09 14:59:12 +0200
commit4e859e9233cabfff7ed81b56781cccbcd90befa4 (patch)
tree91816202d338536b3fdf6e90871c7c1ec939ae9f /gnu
parent70eea6ea14590a5a13656148915bd62f5fecf5f7 (diff)
downloadguix-4e859e9233cabfff7ed81b56781cccbcd90befa4.tar.gz
gnu: eudev: Build the hardware database.
* gnu/packages/linux.scm (usbutils)[inputs]: Replace EUDEV-WITH-HWDB
by EUDEV.
(eudev)[arguments]: New field.
(eudev-with-hwdb): Define in terms of 'deprecated-package'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm25
1 files changed, 11 insertions, 14 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index c101135db7..e345c576ee 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -637,7 +637,7 @@ slabtop, and skill.")
     (build-system gnu-build-system)
     (inputs
      `(("libusb" ,libusb)
-       ("eudev" ,eudev-with-hwdb)))
+       ("eudev" ,eudev)))
     (native-inputs
      `(("pkg-config" ,pkg-config)))
     (home-page "http://www.linux-usb.org/")
@@ -1843,6 +1843,15 @@ from the module-init-tools project.")
               (patches (search-patches "eudev-rules-directory.patch"
                                        "eudev-conflicting-declaration.patch"))))
     (build-system gnu-build-system)
+    (arguments
+     '(#:phases (modify-phases %standard-phases
+                  (add-after 'install 'build-hwdb
+                    (lambda* (#:key outputs #:allow-other-keys)
+                      ;; Build OUT/etc/udev/hwdb.bin.  This allows 'lsusb' and
+                      ;; similar tools to display product names.
+                      (let ((out (assoc-ref outputs "out")))
+                        (zero? (system* (string-append out "/bin/udevadm")
+                                        "hwdb" "--update"))))))))
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("perl" ,perl)
@@ -1861,19 +1870,7 @@ time.")
     (license license:gpl2+)))
 
 (define-public eudev-with-hwdb
-  ;; TODO: Merge with 'eudev'.
-  (package
-    (inherit eudev)
-    (name "eudev-with-hwdb")
-    (arguments
-     '(#:phases (modify-phases %standard-phases
-                  (add-after 'install 'build-hwdb
-                    (lambda* (#:key outputs #:allow-other-keys)
-                      ;; Build OUT/etc/udev/hwdb.bin.  This allows 'lsusb' and
-                      ;; similar tools to display product names.
-                      (let ((out (assoc-ref outputs "out")))
-                        (zero? (system* (string-append out "/bin/udevadm")
-                                        "hwdb" "--update"))))))))))
+  (deprecated-package "eudev-with-hwdb" eudev))
 
 (define-public lvm2
   (package