summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2020-07-25 15:58:21 +0200
committerMathieu Othacehe <othacehe@gnu.org>2020-07-25 16:01:58 +0200
commit554fd0e869567b7782843340143451a8cef612dd (patch)
treedb91a43b2720426fc21d2d745604442b76b03cd4 /gnu
parent20df47e5a390399775908d96e552d7a6696c50bb (diff)
downloadguix-554fd0e869567b7782843340143451a8cef612dd.tar.gz
gnu: Add guile-lzlib.
* gnu/packages/guile-xyz.scm (guile-lzlib): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/guile-xyz.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 0bfb855f46..3f05c0e4c7 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -3726,3 +3726,36 @@ data-compression library.  The bindings are written in pure Scheme by using
 Guile's foreign function interface.")
     (home-page "https://notabug.org/guile-zlib/guile-zlib")
     (license license:gpl3+)))
+
+(define-public guile-lzlib
+  (package
+    (name "guile-lzlib")
+    (version "0.0.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://notabug.org/guile-lzlib/guile-lzlib.git")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0ny4pbig5x1lv83b63c2613gwv98myk3rm44l88ic7lrff6cd2hr"))
+              (modules '((guix build utils)))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:make-flags
+       '("GUILE_AUTO_COMPILE=0"))) ;to prevent guild warnings
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("guile" ,guile-3.0)
+       ("lzlib" ,lzlib)))
+    (synopsis "Guile bindings to lzlib")
+    (description
+     "This package provides Guile bindings for lzlib, a C library for
+in-memory LZMA compression and decompression.  The bindings are written in
+pure Scheme by using Guile's foreign function interface.")
+    (home-page "https://notabug.org/guile-lzlib/guile-lzlib")
+    (license license:gpl3+)))