summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2016-12-30 16:32:14 +0100
committerJulien Lepiller <julien@lepiller.eu>2017-02-15 20:10:36 +0100
commit567b4e029950340ce3219cfd1dcab391858813e1 (patch)
tree0ea3ff5985833c0f2a90a8cc67a3fc3b8670e87a /gnu
parentc333995063614038bc217536ac39ad35f57b3ed7 (diff)
downloadguix-567b4e029950340ce3219cfd1dcab391858813e1.tar.gz
gnu: Add ocaml-ppx-optcomp.
* gnu/packages/ocaml.scm (ocaml-ppx-optcomp): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index ca0674a6d2..5820f1599b 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2067,3 +2067,24 @@ It contains:
 @item a framework for dealing with attributes and extension points.
 @end enumerate")
     (license license:asl2.0)))
+
+(define-public ocaml-ppx-optcomp
+  (package
+    (name "ocaml-ppx-optcomp")
+    (version "113.33.03")
+    (source (janestreet-origin "ppx_optcomp" version
+               "13an8p2r7sd0d5lv54mlzrxdni47408bwqi3bjcx4m6005170q30"))
+    (build-system ocaml-build-system)
+    (native-inputs
+     `(("js-build-tools" ,ocaml-js-build-tools)
+       ("opam" ,opam)))
+    (propagated-inputs
+     `(("ppx-tools" ,ocaml-ppx-tools)
+       ("ppx-core" ,ocaml-ppx-core)))
+    (arguments janestreet-arguments)
+    (home-page "https://github.com/janestreet/ppx_optcomp/")
+    (synopsis "Optional compilation for OCaml")
+    (description "Ppx_optcomp stands for Optional Compilation.  It is a tool
+used to handle optional compilations of pieces of code depending of the word
+size, the version of the compiler, ...")
+    (license license:asl2.0)))